When I try to run E-MAIL, a window pops up indicating that another session is running, but the ps command doesn’t show any other E-MAIL process running

Export to PDF | Export to DOC

Problem: When I try to run E-MAIL, a window pops up indicating that another session is running, but the ps command doesn’t show any other E-MAIL process running.

Cause: A previous E-MAIL process was killed or terminated and the temporary files weren’t removed.

Solution:

Look for any defunct process using the ps command. If nothing shows up, clean the temporary files in /tmp directory. To do this, take the following steps:
  1. List the mailbox file by inode for the user having the problem.
    Example: Assume the user's login is "erick"
      # cd /usr/spool/mail
      # l -i erick
      873 -rw------- 1 erick  group   302 Feb 01 13:40 erick
       ^
       |
       +-- inode
  2. Look in the /tmp directory for a filename starting with the inode number of the user’s mailbox and remove it.
    From the above example:
       # cd /tmp
       # l
       total22
       -rw-r--r--  1  baby    group  0 Feb 01 10:20 intc3624
       -rw-r--r--  1  erick   group  0 Feb 01 13:45 873.296
                                                     ^
                                                     |
               This file starts with the inode       |
               number of erick's mailbox ------------+
  3. Remove the file.
    # rm 873.296
  4. Test SCO Portfolio E-MAIL.

Leave a Reply

Your email address will not be published. Required fields are marked *